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Overview
This example problem is meant to demonstrate the design of a Reinforced Concrete building

structure subjected to floor loads, wind loads and seismic loads.

Seismic Design Data
- Dual system (special reinforced concrete structural walls with special moment frame) in the 

transverse direction

- Special moment frame in the longitudinal direction

- Assigned to a seismic zone III

Methodology
-  Static and Response spectrum analysis
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Overview

Step

00

Figure 1: RC Building Model
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Overview

Step

00

Figure 2: Typical Floor Plan
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Overview

Step

00

Figure 3: Longitudinal Section
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EN(RC)
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Step

00

Building Structure Elements

Applied Code

Details of the Reinforced Concrete Building (1)

Applied Load

Concrete C30/37

Materials

Section ID Dimension Description

1 600x600mm Edge columns

2 750x750mm Interior Columns

3 500x600mm Beam

4 450mm thick Walls

Load Description Intensity

Dead Load Self Weight

Typical Floor Load
Dead Load

Live load

8 kN/m2

2 kN/m2

Roof Load
Dead Load 

Live load

7 kN/m2

1.5 kN/m2

Wind Load X, Y direction EN-1(2005)

Earthquake Loads X, Y direction EN-8(2004)
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Step

01 1-1.Initialization of workspace

Procedure

Starting Midas Gen

1 Main Menu>File>> New Project

2  Check the units on the lower 
right corner of the screen.

2

1
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Step

01

Procedure

1 Set UCS to X-Y Plane>> Origin 

0,0,4

2 Click on Apply And OK

1-2.Setting UCS to XY Plane

Menu>Structure>Select UCS/GCS

1

2
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Step

01

Procedure

Generate the required gridline system

Menu>Structure>Grids>Define Line Grid

1 Add

2 Name it 2F,

3 Add X grid lines

4 Relative 

Lines: 7@8

5 Add Y grid lines and

Relative Lines: 3@6.75

A dialog box depicting the 

Gridlines appears. Click OK

Click [Apply]

1-3. Generation line grid

1

4

5

2

3
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Step

02 2-1. Defining the Material & Frame Section Properties. (1)

Procedure

1 2

3

4

Defining Material Properties

Menu>>Properties>Material

1 Add

2 Material Data:

Material id: 1 

Name: ConcM30

3 Type of Design: Concrete

Standard: EN(RC)

DB: C30/37

4 Click OK
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1
2

3

4
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Step

02 2-1. Defining the Material & Frame Section Properties. (2)

Procedure

Defining Frame Section Properties

Menu>Properties>Section properties >Add

2

3

5

Section ID:1 

Solid rectangle

Name: Edge Columns

User

2 H=0.6m B=0.6m

Similarly define the other Frame Section 

Properties.

Name: Interior Columns

H=0.75m and B=0.75m

Name: Beams H=0.6m and 

B=0.5m

3 Click [Apply] > [Close] 

4  For the Shear Walls: Add 

‘Thickness’ Section Value>> In plane 

and out of plane=0.45m

5 On creating the wall, it is Displayed in 

the dialog box

4

1
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3

4

5
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Step

03 3-1. Generation of Floor layout (1)

Procedure

Generate the Beams

Menu>Model>Elements>Create 

Element

2

1

1 Select material as C30/C37 and 

section as Beam

2 Make sure that Intersect at nodes and 

Elements is on. To create a beam,

click on Nodal connectivity tab

and select the origin as the first 

point and the Node 8 as the last 

point.

The beams between these two points 

are formed breaking at each node

Similarly mark the other 

beams. Click [Close]
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Step

03 3-1. Generation of Floor layout (2)

Procedure

Generate Columns

1 Click GCS

1

2

3

4

2 Main Menu>Elements> Extrude

Elements

3 Node to Line elements, 

Reverse I-J, Select material as

M30 and section as edge columns

4 Translation Distance as -4 

Along Z axis.

5 Select all the nodes

6 Click on Apply

6

5
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Step

03 3-1. Generation of Floor layout (3)

Procedure

1 Works> Edge columns> Active. 

Select the columns whose 

property has to be changed.

Modify the Property of Columns:

( To Change the property of certain 

exterior columns to Interior)

1

2

2 Views>Display options>

Property Name

3 Now from the Works Menu, 

Drag and Drop Interior Column

3
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3

Step

03 3-1. Generation of Floor layout (4)

Procedure

1 Location where we need to create

the shear wall.

2 Main Menu >Node/Elements >

>Create Elements

Generation Shear Walls

1

3 Select Element Type > Wall

4 Select Nodal Connectivity

All the four nodes of the Shear 

Columns if present, should be

Deleted.

4

2
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Step

04 4-1. Generation of Building Model.

Procedure

2 The building is generated as 

shown

Building Generation

Menu>View>Select>Select All
1

1 Menu> Structure>Building> 

Building Generation

No of Copies: 11

Distance (Global Z): 3.15m 

Click Add and Apply

2
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4-2. Automatic generation of the story data

2

1

Procedure

Click [Auto Generate Story Data] 
button. This will create the data 
needed to generate diaphragms 
for each floor

1

2  Click [OK]

3  Click [Close] 3
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Menu> Structure > Building > Story

Step

04
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Step

06

4

Procedure

1 Select the ends of all the columns 

from the elevation view.

2 Menu>Model>Boundaries> 

Supports

3 Select the property of Fixed 

Support i.e. D- all, R- all.

Click on Apply

The lower ends of the Columns 

are assumed fixed

6-1. Boundary Conditions

4

2

1

3
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Procedure

Click : [Close]

Step

07

1 Add the loads and their details

2

7-1. Loading Data (1)

1

2
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Menu>Load>>Static Load Cases
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Step

07 7-1. Loading Data (2)

Procedure

1 Menu> Load>>Self Weight

2 Load Case Name: DL

Z=-1

3 Add

4 In the Work Tree menu, Self

Weight will be displayed

1

2

3

4

http://en.midasuser.com Midas Information Technology Co., Ltd.

http://en.midasuser.com/


Procedure

When you click on Add, The

Load appears in the dialog Box

1 Name: Typical Floor

DL: -8kN/m2

LL: -2kN/m2

Similarly define the Roof Load 

DL: -7kN/m2

2 LL: -1.5kN/m2

Step

07 7-1. Loading Data (3)

1

2
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Menu>Load>>Define Floor Load Type
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Copy Floor load: 10@3.15

(Total 10 floors and each floor di 
stance is 3.15m)

To select the floor area, first 

Select Nodes Defining Loading 

Area wherein You need to 

Select the nodes . On the last 

Click, the load is applied.

Similarly assign the Roof Load 

But be careful to unselect the 

Copy Floor load option.

1  Name: Typical Floor

Step

07

2

Procedure

Menu>Load>Assign Floor Load

7-1. Loading Data (4)

2

1
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Procedure

1 Structure type: 3-D

Mass Control Parameter:

Lumped Mass

Convert Self-Weight into 

masses

Convert to X,Y 

Gravity Acceleration: 

9.806 m/sec2

Step

07 7-2. Convert Model Weight & Loads to Masses (1)

1

Menu>Structure > Structure type
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Procedure

1  Mass Direction: X,Y 

Load Case / Factor: 

DL: 1

Click Add 

LL: 0.25

Click Add

On clicking Ok, Such a model

is generated

Step

07

1

7-2. Convert Model Weight & Loads to Masses (2)

Menu>Load > Masses> Loads to 

Masses
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Procedure

Step

07

1 Load Case Name : WX

Wind Load Code : EN-1(2005) 

Basic Wind Speed: 26m/s 

Terrain Category: II

Building Height: 38.65m

Wind Load Direction Factor

for X: 1 rest all will 

Be 0. Click Apply

Similarly assign the Load 

parameters for WY

2  The loads are summarized in 

The dialog box

7-3. Wind Loads

2

1Menu>Load > Lateral Loads > 

Wind Loads > Click [Add]
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1

2
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Procedure

Step

07

1 Fill in the details as shown.

2 Calculating time period , use period

Calculator for Auto-calculation of periods 
from the code equations

Menu>Load >Lateral Load>Static 

Seismic Loads

1

3 On defining all the load cases 

Such a dialog box appears.
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7-4. Static Seismic Loads

1

3

2
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Procedure

Step

07

2

7-4. Static Seismic Loads (Seismic Profile)

Menu>Loads> Lateral Loads>

Static Seismic Loads
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Select Load Case Name EXP> 
Modify

1 Seismic Load Profile

2 X-Dir (on)

Story Force (on)

Conform Story Shear of Base 

floor

1

2

1
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Procedure

1 Add > Function Name:

Design Spectrum

2 Generate Design Spectrum: 

Design Spectrum: EN-8(2004)

3 Spectrum type : Horizontal         

Elastic spectrum

Spectrum Parameters: type 1

2 Importance Factor: 1

Viscous Damping Ratio: 5 

Click OK

Such a Dialog Box appears. 

Click OK

The Response Spectrum . 

Function is generated

Step

07

2
1

Menu>Load>Dynamic loads> 

Response Spectrum functions

3

7-5. Response Spectrum Functions
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3

2
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Procedure

Click [Close]

Step

07

1 Load Cases Name : RX 

Excitation Angle : 0

2 Check : EURO 2004

3 Click [Add]

4 Load Cases Name : RY 

Excitation Angle : 90

> Click [Add]

5 The two Spectrum Load Cases 

Are created

7-6. Response Spectrum Load cases

2

Menu>Load>Response Spectrum 

Analysis Data > Response 

Spectrum Load Cases
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5
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Procedure

Fill in the details as shown.

Step

07

1

7-7. Eigen Analysis Control

1

Menu>Analysis> Eigen value Analysis 

Control
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Procedure

Step

08

1

8-1. Analysis and Results

1Menu>Analysis>Perform Analysis

Menu>Results > Result Tables > 

Story >Reaction>

Select EXP, EYP and RX and RY

2

2

3  Calculate the ratio of 

EXP/RX(RS) and EYP/RY(RS)

3
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EXP/RX(RS) =2.13

EYP/RY(RS) =1.38
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Procedure

Auto Generation

Scale Up Factor: RX 1.500 

Scale Up Factor: RY 1.00

Step

09

2

9-1. Automatic generation of load combinations

3  Select Design Code as

“Eurocode 2:04 ”

> Click [OK]

> Click [Close]

1 Select Concrete Design tab
3

1

2
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Menu>Results > Combinations >

Concrete Design

3

2

1
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Step

10

Procedure

1 X-direction > Unbraced 

Sway (on)

Y-direction > Braced 

Non-Sway (on)

Design Type > 3-D 

Click OK [Close]

Design > Concrete Design 

Parameter > Design Code 

Design Code > EN 2 :2004

10-1. Design (1)

1

Menu>Design > General Design

Parameter >Definition of Frame
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Step

10

1 Fill in the details as per 

Requirements for every 

Structural element

2 Click on Input Additional Wall

Data

3 Select any End Rebar Design 

Method

1

10-2. Design (2)

2
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3

Menu>Design > RC Design >Design

Criteria for Rebar

Procedure

3

2
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Step

10

Procedure

Select material ID #1 

Rebar Selection 

Code > EN(RC)

Grade of Main Rebar > S400 

Grade of Sub-Rebar > S400 

Click Modify

1
1

10-2. Design (3)

Menu>Design > RC Design>Modify

Concrete Materials
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Step

10

Procedure

1 Sorted by > Member (on)

Similarly Design The column 

And Shear wall.

10-3. Design Output (Beam)

1
Menu>Design > RC

Design > Concrete code design>

Beam Design
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Step

10

Procedure

Conform Detail Calculation report 

as per EN 2 :2004

10-3. Design Output (Beam)

1
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2

2

Menu>Design>RC design> 

Concrete code design> 

Beam Design

1 Click Detail…

2

1
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Step

10

Procedure

Sorted by > Member (on)1

10-3. Design Output (Column)

1
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Menu>Design > RC

Design > Concrete code design>

Column Design

1
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Step

10

Procedure

Sorted by>Wall ID+story 

and select a wall>Graphic

Such a window explaining the 

design would be displayed

1

10-3. Design Output (Wall)

Menu>Design > RC

Design > Concrete code design>

Shear wall design
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