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Steel Structure

Program Version Gen 2024 (v2.1)

Revision Date Mar. 19, 2025

This Tutorial presents an efficient method of modeling and analyzing a plant structure.

The Install CD provides an animation illustrating all the modeling, analysis and results 

verification processes of the present example with concurrent vocal explanations. The tutorials 

are much easier to follow if the entire process of analysis is first understood through the 

narrated animations.

The step-by-step modeling and analysis processes presented in this example are the following:



Step

00 Overview
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Applied Load

www.MidasUser.com

Applied Code

Details of the Plant Structure

Eurocode Section ID Section type Description

1 HEA 400 Exterior Columns, Roof level girder

2 HEA 500 Interior Columns

3 HEA 260 Floor girders/ beam

Platform SectionMaterials

S 460

Load Description Intensity

Dead Load Self Weight

Live Load
Outer Girder 

Inner Girder
11.5 kN/m

5.6 kN/m

Roof Load Wind Load 5.4 kN/m

Wind Load

Wind X (inner) 

Wind X ( outer) 

Wind Y (inner) 

Wind Y(outer)

4.9 kN/m

9.8 kN/m

2.7 kN/m

5.5 kN/m

Step

00
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Step

01

Procedure

1 Main Menu>File> New Project

2 Check the units on the lower right
corner of the screen.

2

www.MidasUser.com

Starting Midas Gen

1

1-1. Initialization of workspace

1

2
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Step

01

Procedure
Generate the required gridline system

Menu>structurel>Grids>Define Line 

Grid

1 Add Line Grid

Name it 2F, Add X grid lines

Relative 

Lines: 2@10 Similarly 

Add Y grid lines Relative

Lines: 4@8

A dialog box depicting the Gridlines 

appears. Click OK

Click [Apply]

1-2. Generation of Line Grid

www.MidasUser.com

4

3

2

1

1

2

3

4
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Step

02

Procedure

Menu>Model>Properties>Material

1 Material ID :1

Type of Design : Steel 

Standard Code EN(S)

 Type of steel : S460

www.MidasUser.com

2-1. Defining the Material Type.

1
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Step

02

1 Section ID:1 

I Section

Name: Exterior Columns, 

Roof level girder

Section Name: HEA400 

Click [Apply] > [Close]

2 Similarly define the other 

Frame Section Properties.

Defining Frame Section Properties

Menu>Model>properties>Material 

properties>Section

Procedure

2-2. Defining Frame Section Properties.
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Step

02

1 Section ID:2

 I Section

Name: Interior Columns, 

Section Name: HEA500 

Click [Apply]

1 .

2 SectionID:3

I Section

Name: Floor girders, 

Section Name: HEA260 

Click [Apply]

Defining Frame Section Properties

Menu>Model>properties>Material 

properties>Section

Procedure

2-2. Defining Frame Section Properties.
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Step

02

Section ID:4 

Double Angle Section

Name: top and bottom chord,

Section : User defined 

Provide the section values as per 

the image 

Click [Apply]

Section ID:5

Angle Section

Name: Roof Bracing, 

Section : User defined 

Provide the section values as per 

the image  

Click [Apply]

Defining Frame Section Properties

Menu>Model>properties>Material 

properties>Section

Procedure

2-2. Defining Frame Section Properties.
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Step

02

Section ID:6 

Double Angle Section

Name: Diagonal members,

Section : User defined 

Provide the section values as per 

the image 

Click [Apply]

Section ID:7

Double Angle Section

Name: Wind Braces, 

Section : User defined 

Provide the section values as per 

the image  

Click [Apply]

Defining Frame Section Properties

Menu>Model>properties>Material 

properties>Section

Procedure

2-2. Defining Frame Section Properties.
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Procedure

Generating Nodes

Menu>Nodes>Create Nodes

1  Distance dx,dy,dz: 0,0,0

(Click select single          on the 

respective node)

Then, Menu>Nodes>

Translate nodes

Distance dx,dy,dz:10,0,0

No of times : 2

Click apply

Distance dx,dy,dz:0,8,0

No of times : 4

Click apply

www.MidasUser.com

Step

03 3-1. Generation of nodes

2

(Note: select single on this ribbon bar)

1

2
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1

1  Select the nodes of the
exterior columns

2 Extrude Elements 

Extrude type: Node- Line 

Element Type: Beam 

Material type: S460 

Section: Exterior Columns

Translation: Equal Distance 

dx,dy,dz: 0,0,4

No of times: 1

3 Click [Apply] > [Close]

Mark the External Columns

Using Extrusion

Menu>Elements>Extrude Elements

3

Procedure

www.MidasUser.com

Step

03 3-1.1 Generation of Platform layout (Exterior Column)

1

2

1

3
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Step

03

Click [Apply] > [Close]

1 Select the nodes of the 

Interior column

2 Extrude Elements 

Extrude type: Node- Line 

Element Type: Beam 

Material type: S460 

Section: Interior Columns

Translation: Equal Distance 

dx,dy,dz: 0,0,4

No of times: 1

Mark the Internal Columns

Using Extrusion

Menu>Model>Elements> 

Extrude Elements

4

1

Procedure
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3-2. Generation of Platform layout (Interior Column)

1

2
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Step

03

Generating the floor girders 

Menu>Model>Elements > 

Create Elements

1

1 Create Elements

Element type: General beam

Material type : HEA260

 Section: Floor Girder

Check on Node and Element 

Intersect

Procedure

2 Click Nodal Connectivity and 

using the cursor click the top 

of columns

Click [Apply] > [Close]

2
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3-3.1. Generation of Platform layout (Floor Girders)

2

1

http://www.MidasUser.com/


Procedure

Step

03

Generating the remaining

Floor Girders

Menu>View>Select>Single

Right Click on Model view screen

>Elements>Translate

1

1 Translate Elements 

Mode: Copy

Equal Distance: 10,0,0 

Number of Times : 2

Click [Apply] > [Close]

3-3.2. Generation of Platform layout (Floor Girders)

www.MidasUser.com

1
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Create Elements

Element type: General beam

Material type: S460

Section: Floor Girder

Check on Node and Element

 Intersect

Click Nodal Connectivity and 

using the cursor click the top 

of columns

Click [Apply] > [Close]

1

2

Generating the transverse

floor girder

Right Click on Model view screen 

Elements > Create Elements
1

2

Step

03

Procedure

www.MidasUser.com

3-3.3. Generation of Platform layout (Floor Girders)

2

1
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Step

03

Generating the remaining 

Floor Girders

Select the beam as highlighted 

Right Click on Model view screen 

Elements>Translate

1 Translate Elements 

Mode: Copy

Equal Distance: 0,-8,0 

Number of Times : 3

2 The beams are created.

Click [Apply] > [Close]

Procedure

www.MidasUser.com

3-3.4. Generation of Platform layout (Floor Girders)

1

2
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Step

03

1 Divide Elements 

Element Type : Frame 

Equal Distance

Number of Divisions x : 4

(This operation divides the beam 

into 4 equal segments, with 3 

intermediate nodes)

The beam gets divided into 4 

parts

2 Click [Apply] > [Close]

Dividing an element

Select the beam as highlighted. 

Right Click on Model view screen 

Elements>Divide

Procedure
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3-3.5. Generation of Platform layout (Floor Girders)

2

1

http://www.MidasUser.com/


Step

03

Procedure

Generating the remaining

Longitudinal Floor Girder

Select the beam as highlighted.

Right Click on Model view screen

Elements>Extrude

1 Extrude Elements

Extrude type: Node- Line

Element Type: Beam

Material type: S460

Section: Floor Girder

Translation: Equal Distance

dx,dy,dz: 0,-32,0

No of times: 1

2 The longitudinal girders are
created

Go to intersect elements select all the 3                                   

longitudinal griders and give apply. 

Click [Apply] > [Close]

www.MidasUser.com

2

3-3.6. Generation of Platform layout (Floor Girders)

3

1

3

1
2,3
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Step

04

Procedure

www.MidasUser.com

Generate wind braces

Right Click on Model view screen 

Elements > Create Elements

1

1 Create Elements 

Element type: Truss 

Material type: S460 

Section: Wind Braces

Check  on  Node  and  Element

Intersect

Click on the corner node and the
center of the beam .

(The program automatically 

detects the center point of 

the beam)

Create the other wind bracings. 

Click [Apply] > [Close]

4-1 Generation of Wind Braces

1
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Step

04

Click [Apply] > [Close]

1 Translate Elements 

Mode: Copy

Equal Distance: -10,0,0(for 

X directional bracings)

0,-32,0 (for Y directional 

bracings)

Number of Times : 2
2 All the bracings are generated

Generate remaining Wind Braces

Menu>View>Select>Single 

Right Click, Elements>Translate

1

2

Procedure

www.MidasUser.com

4-1.1. Generation of Remaining Wind Braces

2

1

1

2

X directional bracings 

Y directional bracings
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Step

05

Generate remaining Storey’s by

Translation

Menu>View>Select>Select All 

Right Click, Elements>Translate

1 Translate Elements 

Mode: Copy

Equal Distance: 0,0,4 

Number of Times : 1

The entire structure is created. 

Click [Apply] > [Close]

1

Procedure

www.MidasUser.com

5-1. Generation of Storey

1

2

3

2

3

1

1
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Step

05

Click [Apply] > [Close]

1 Extrude Elements 

Extrude type: Node- Line 

Element Type: Beam 

Material type: S460 

Section: Ext Column

Translation: Equal Distance 

dx,dy,dz: 0,0,4

No of times: 1

Generate remaining roof columns

Menu>View>Select>Single 

And select the nodes as shown 

Right Click, Elements>Extrude

Procedure

www.MidasUser.com

1

5-2. Generation of Platform layout (Columns)

3

3

2

1

1
2
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Procedure

Step

06

Generate Roof Truss

Structure>Wizard>Base 

structures> Truss.

From  the input tab, enter the
parameters as shown in the figure

2  From the Edit tab, enter the 

verticals , material and section 

type as shown in the figure

2  From the insert tab, use node 1 of 
the truss to coincide with node 68 
of the frame model.

Click [Apply] > [Close]

www.MidasUser.com

1

6-1. Generation of Truss

2 43

5

1

2

4

3

5

1
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Step

06

1 The roof truss is placed at the top

We need to insert the verticals.

2 Menu>View>Select>Single

3  Menu>View>Activities>Active(F2)

Activating the truss to be Worked on.

3

2

1
Procedure

6-2. Generation of Vertical members of the Truss (1)
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Procedure

Step

06

1 Create Elements 

Element type: Truss 

Material type: S460

Section: diagonal members

Check  on  Node  and  Element
Intersect

Create the vertical and diagonal 

member as shown in the figure 

(The program the automatically
detects the center point of the
member)

Generating the vertical 

members of the truss

Right Click , Elements > 

Create Elements
1

www.MidasUser.com

6-3. Generation of Vertical members of the Truss (2)

1

1
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Step

06

Generating the remaining

Truss

Menu>View>Select Previous 

Right Click, Elements>Translate

1 Translate Elements 

Mode: Copy

Equal Distance: 0,4,0 

Number of Times : 8

2 The entire roof truss is created.

2

Procedure

www.MidasUser.com

6-4. Generation of Trusses (1)

2

1
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Step

06

The floor girders are created

on one side. 

Click [Apply] > [Close]

1 Create Elements

Element Type: General beam/ 

Tapered beam

Material type: S460 

Section: Ext Column

Generating the roof beam

girder

Activate the roof truss only

Change the view as  per your

convenience.

Right Click, Elements> 

Create Elements

1

Procedure

www.MidasUser.com

6-5. Generation of Trusses (2)

2

2

3

1

1,2
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Step

06

The floor girders are created

completely over roof truss. 

Click [Apply] > [Close]

1 translate Elements

1 Translate Elements 

Mode: Copy

Equal Distance: 4,0,0 

Number of Times : 5

Generating the roof beam

girder

Activate the roof truss only

Change the view as  per your

convenience.

Right Click, Elements> 

translate Elements

1

Procedure

www.MidasUser.com

6-5. Generation of Trusses (2)

2

2

3

1

3
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Step

06

1 Menu>View>Select>Single
select the upper level beams as
highlighted in the figure.

Menu>View>Activities>Activate 
(shortcut key is F2)  to activate 
the selected beams only.

2 Change the view to isometric

Creating the roof bracing

Menu>View>View Point>Front

2

1

Procedure
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6-6. Generation of Roof Bracing (1)

2

1

2
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Step

06

1  Create Elements 

Element type: Truss 

Material type: S460 

Section: Roof Bracing

Check off Node and Element 

Intersect.(We do not want the 

bracing to intersect each other)

Click [Apply] > [Close]

Creating the roof bracing

Right Click , Elements > Create 

Elements

Procedure

www.MidasUser.com

6-7. Generation of Roof Bracing (2)

1

2
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Step

06

The roof bracings are created.

1 Translate Elements 

Mode: Copy

Equal Distance: 0,4,0 

Number of Times : 7

( For the last row bracing we copy 
it 7 times ,and for the others we co 
py it 2 times)

Generating the remaining 

Wind braces by Translation

Menu>View>Select>single 

Select roof bracings, as shown in 

the figure.

Right Click, Elements>Translate

2

2

1

Procedure
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6-8. Generation of Roof Bracing (3)

1
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Step

07

Generating the supports at base

Menu>View>View Point>Front 

Menu>View>Select>single 

Menu>Model>Boundaries>Supports

1 Supports 

Option: Add

D-All: Checked in 

R-All: Checked in

Fixed supports are generated.

Click [Apply] > [Close]

Procedure
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7-1. Generation of Fixed Supports

1
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Procedure

Step

08

1 Name: Self Weight 

Type: Dead Load

Define the remaining loads 

according to their Specifications 

as shown in the dialog box

www.MidasUser.com

Creating Static Load cases

Menu>Load> Static Load Cases

8-1. Creating Static Load Cases

1
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Step

08

Procedure

Applying the self weight of the

structure in load case 1: SW

Menu>Load>Self Weight

1  Load Case Name: SW 

Self Weight factor:

Z: -1

Click [Add] > [Close]

1

2  In the Work Tree menu, Self 

Weight will be displayed 2

8-2. Applying the Self Weight

www.MidasUser.com
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Step

08

Procedure

1 Load Case Name : LL 

Load Group Name: Default 

Options: Add

Load Type: Uniform Loads 

Direction : Global Z

Value : Relative

x1 = 0 ; x2 = 1 ; w = -11.5KN/m

(On the outer girder we apply 

udl of -5.6KN/m and on the 

inner girders the udl is of

-11.5 KN/m)

Click [Apply] > [Close]

Applying an uniform distributed load 

as live load of the structure in load 

case 2: LL

Menu>Load>Element Beam Load

8-3. Applying the Live Load

www.MidasUser.com
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Step

08

Procedure
Applying an uniform distributed load 

as wind load on the  X direction 

outer columns of the structure in 

load case 3: Wind X +

Right Click, Loads> Element Beam

Load

1 Element Beam Load

Load Case Name : Wind X +

Load Group Name: Default 

Options: Add

Load Type: Uniform Loads 

Direction : Local Z

Value : Relative

x1 = 0 ; x2 = 1 ; w = 9.8KN/m

(An udl of 4.9KN/m, 9.8KN/m,

2.7KN/m and 5.5KN/m has been 

applied on the columns)

Click [Apply] > [Close]

1

8-4. Applying the Wind Load (Wind X +)
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Step

08

Procedure

1 Applying an uniform distributed
load as wind load on the X and

Y direction outer columns of the

structure in load case 4, 5 and 6:

Wind X - ,Y +  and Y –

2 Similarly, we generate the

wind load as udl on the other
directions (X -, Y + and Y -) and

on the roof truss

www.MidasUser.com

Load Description Intensity

Dead Load Self Weight

Live Load
Outer Girder 

Inner Girder
11.5 kN/m

5.6 kN/m

Roof Load Wind Load 5.4 kN/m

Wind Load

Wind X (inner) 

Wind X ( outer) 

Wind Y (inner) 

Wind Y(outer)

4.9 kN/m

9.8 kN/m

2.7 kN/m

5.5 kN/m

8-5. Applying the Wind Load (Wind X -, Y+ and Y-)
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Step

09

Procedure

The short-cut is available on

the Tool Bar.

a. Perform Analysis

b. Preprocessor

c. Postprocessor

1

a b c

Performing Analysis

Menu>Analysis>Perform Analysis

1

Click Analysis in the Icon Menu or select Analysis>Perform Analysis in the Main Menu to 

analyze the model. Once the analysis is completed, the program switches automatically to the 

post-processing mode, which provides access to the analysis and design results.

Click Preprocessing Mode in the Icon Menu or select Mode> Preprocessing Mode in the

Main Menu when the preprocessing mode has to be restored to modify the data.

9-1. Performing Analysis

www.MidasUser.com

Note: Remove beam end releases before performing analysis 
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Step

10

Procedure

Click on Select Design Code 

Eurocode3:05

Click [OK] > [Close]

1

Assigning the Code of practice for 

load combination Generation 

Menu>Results > Load 

Combination > Steel Design> Auto 

Generation

* The load combinations, in conformity with the Limit State 

Design Method, are auto-generated by Auto Generation. 

Additional Service Load combinations may be entered to 

examine displacements and reactions

1

www.MidasUser.com

10-1. Automatic Generation Of Load Combinations
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Step

10

Procedure

Menu>Results >Reactions> 

Reaction forces/Moments

1 Load Cases/Combinations 

CBS:sLCB10

www.MidasUser.com

1

10-2. Verification of Reactions (1)
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Step

10

Procedure

Menu>Results >Deformations> 

Displacement Contour

1 Load Cases/Combinations 

CBS:sLCB10

2 Click on values for displaying, 

for Animation check Animate

2

10-3. Displacement contour (2)

www.MidasUser.com
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Step

10

Procedure

Menu>Results >Forces> 

Beam diagrams

1 Load Cases/Combinations 

CBS:sLCB10

2 Click on Values for displaying

1

10-4. Verification of Member (3)

www.MidasUser.com
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Step

11

Procedure

Menu>Design>> Steel Design 

Parameter

1  Design Code > Eurocode3:05

www.MidasUser.com

Assigning the Code of practice for 

designing the structure

11-1. Design (1)

1
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Step

11

Procedure

Menu>Design> Steel Code Check

1  Member (on) Click on Graphic

Select the structural element you 

would like to view the graphic 

detailing of

www.MidasUser.com

11-2. Design (a)

http://www.MidasUser.com/


Step

11

Procedure

Menu>Design> Steel Code Check

1 Click on Detail

Select the structural element

you would like to check

A window explaining the 

design logic of the structural 

element appears with 

detailed relevance to the IS 

Code

www.MidasUser.com

1

11-2. Design (b)
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Step

11

Procedure

1 Select the structural element 

you would like to optimize, 

click on change

2 Click on Search Satisfied 

Section. Make sure the Limit 

Combined ratio is as per your 

preference.

Such a dialog box with the 

available optimum options 

appears

www.MidasUser.com

2

Menu>Design> Steel Code Check

11-3. Design (optimising design)
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